Firefox and Security Add-Ons for Linux - Secure Web Browser

Publié10 August 2016

Table des matières

...Loading Table of Contents...

    Mozilla Firefox (aussi connu sous le nom de Firefox) est un navigateur internet libre et gratuit amélioré par de nombreux modules complémentaires disponibles, notamment certains modules qui sont conçus pour protéger votre vie privée et votre sécurité lorsque vous effectuez des recherches sur Internet.

    Lectures préalables

    Ce que vous apprendrez dans ce guide

    • Comment utiliser un navigateur Internet stable et sûr présentant de nombreux modules complémentaires.
    • Comment vous protéger de programmes et sites Internet potentiellement dangereux.
    • Comment effacer les traces numériques de vos activités de navigation.

    1. A propos de Firefox

    Ce guide suppose que vous savez déjà utiliser un navigateur internet et ne couvre pas les fonctions de bases de Firefox. Le guide se concentre sur les paramétrages et les extensions liés à la sécurité.

    1.0. A SAVOIR SUR FIREFOX AVANT DE COMMENCER

    Firefox dispose de nombreux modules complémentaires faciles à utiliser qui améliorent votre vie privée et votre sécurité lorsque vous effectuez des recherches sur Internet. Vous pouvez choisir quels modules complémentaires ajouter et décider de la façon dont vous les configurez selon les circonstances. Si vous utilisez un ordinateur géré par quelqu'un d'autre (dans un cybercafé par exemple, ou sur votre lieu de travail), vous aurez peut-être à faire ces réglages à plusieurs reprises. En plus des paramétrages de bases de Firefox, ce guide couvre l'installation et la configuration de base des modules complémentaires suivants :

    Ce centre de ressources App Centre fournit des informations sur les modules complémentaires supplémentaires permettant d'améliorer les paramètres de vie privée sur les navigateurs.

    Important : La grande majorité des infections par des logiciels malveillants ou espions viennent de pages Internet. Il est important de toujours vérifier s'il est sans danger de visiter des sites Internet inconnus, particulièrement ceux qui vous sont envoyés par email. Avant de décider d'ouvrir une page Internet, nous vous recommandons de vérifier l'adresse Internet en utilisant les url de vérification suivant :

    Vous pouvez aussi vérifier la réputation d'un site Internet en utilisant les outils de vérification listés ci-dessous :

    1.1 Autres outils similaires à Firefox

    Outils similaires et alternatifs pour les autres systèmes d'exploitation.

    Le navigateur Internet Mozilla Firefox est compatible avec GNU/Linux, Apple Mac OS X, Microsoft Windows et d'autres systèmes d'exploitations. Les sites Internet sont la source la plus courante d'infection par des programmes malveillants, l'accès à ces sites en toute sécurité est donc vital. Nous vous recommandons d'utiliser Mozilla Firefox et d'installer les modules complémentaires présentés dans ce guide. Si vous préférez utiliser un autre programme que Mozilla Firefox, les alternatives suivantes sont aussi compatibles avec GNU/Linux, Apple Mac OS X et Microsoft Windows :

    2. Installer, configurer et utiliser Firefox

    De nombreuses distributions Linux sont déjà équipés par défaut de Firefox, et la plupart ont un système de gestion de paquets ou une logithèque qui facilite l'installation et la mise à jour de Firefox (ainsi que des logiciels supplémentaires nécessaire à son fonctionnement).

    Astuce. De nombreuses distributions Linux proposent une version sans marque déposée de Firefox appelée Iceweasel, qui est exactement le même outil avec un nom différent.

    2.1. Installer ou mettre à jour Firefox

    Vous avez probablement Firefox (ou Iceweasel) déjà installé. Mais, si ce n'est pas le cas - ou si vous avez besoin de le mettre à jour - vous pouvez suivre les instruction de l'une des sections ci-dessous. Il est extrêmement important de maintenir votre navigateur internet à jour. Firefox est plus facile à mettre à jour si vous l'installez en utilisant votre gestionnaire de paquets ou logithèque, nous vous recommandons donc d'utiliser l'une des premières méthodes ci-dessous. Mais si, pour une raison quelconque, vous avez la dernière version de Firefox - ou si vous souhaitez installer la version portable Firefox (sur un périphérique de stockage par exemple) - la section Installer Firefox directement depuis le développeur vous indiquera comment procéder.

    Astuce: Généralement, c'est une bonne idée d'utiliser la version la plus récente d'un logiciel lié à la sécurité de votre appareil, y compris pour les navigateurs Web. Cependant, les distributions Linux incluent souvent des mises à jour de sécurité pour les "anciennes" versions de Firefox dans leur gestionnaire de paquets ou leur logithèque. Pour cette raison (et parce que ces versions sont plus faciles à mettre à jour) nous recommandons généralement d'installer et de mettre à jour Firefox en utilisant un gestionnaire de paquets ou la logithèque intégrée.

    2.1.1 (Facultatif) Installer ou mettre à jour Firefox par la ligne de commande du gestionnaire de paquets

    Pour installer ou mettre à jour Firefox en utilisant la ligne de commande du gestionnaire de paquets apt disponibles pour de nombreuses distributions Linux (y compris Debian et Ubuntu), suivez les étapes ci-dessous.

    Première étape. Ouvrez le Terminal

    Deuxième étape. Exécutez la commande suivante dans le Terminal

    sudo apt-get update

    Troisième étape. Saisissez le mot de passe que vous utilisez pour vous connecter à votre ordinateur et appuyez sur Entrée.

    Ceci actualisera la liste des logiciels que votre gestionnaire de paquets est en mesure d'installer et mettre à jour.

    Quatrième étape. Exécutez l'une des commandes suivantes dans le Terminal

    • sudo apt-get install firefox
    • sudo apt-get install iceweasel

    2.1.2 (Facultatif) Installer ou mettre à jour Firefox en utilisant votre "logithèque"

    Pour installer ou mettre à jour Firefox en utilisant votre application "logithèque", suivez les étapes ci-dessous.

    Astuce: Les instructions de cette section s'appuient sur la distribution Linux Ubuntu, mais de nombreuses autres distributions contiennent également des logithèques. Certaines versions de Debian sont équipés d'une application appelée Synaptic Package Manager (gestionnaire de paquets synaptique), qui fournit des fonctionnalités similaires. Si vous ne trouvez pas une application appelée Firefox, cherchez celle appelée Iceweasel. Comme mentionné précédemment, il s'agit de la même application mais avec un nom différent.

    Première étape. Lancez la logithèque

    Figure 1: La logithèque Ubuntu

    Deuxième étape. Cliquez dans la barre de recherche

    Troisième étape. Tapez "Firefox"

    Figure 2: Recherche de Firefox

    Quatrième étape. Cliquez sur le résultat pour Navigateur Internet Firefox

    Figure 3: Logithèque indiquant que Firefox est déjà installé

    Si le bouton à droite indique [Installer], vous pouvez installer Firefox. Si il indique [Supprimer], alors Firefox est déjà installé. Même s'il est déjà installé, vous devriez cependant vous assurez qu'il est à jour en suivant les étapes ci-dessous.

    Cinquième étape. Lancez l'application Software Updater (Mise à jour de logiciel) disponible avec votre distribution Linux. (Si vous ne l'avez pas, consultez la section Installer ou mettre à jour Firefox par la ligne de commande du gestionnaire de paquets). Cela lancera automatiquement l'actualisation de la liste des logiciels qu'il sait installer et mettre à jour.

    Figure 4: Outil de mise à jour des logiciels Ubuntu mettant à jour sa liste de logiciels

    Lorsque c'est terminé, vous serez averti si l'un des logiciels de votre ordinateur (y compris Firefox) est périmé.

    Figure 5: Outil de mise à jour des logiciels Ubuntu indiquant que tous les logiciels sont à jour

    Si vous êtes à jour, vous pouvez cliquez sur [OK]. Si l'un de vos logiciels nécessite une mise à jour, nous vous recommandons de suivre les instructions du Software Updater et de mettre à jour Tout. Vous devriez ensuite redémarrer votre ordinateur au plus tôt à votre convenance.

    2.1.3 (Facultatif) Installer Firefox directement depuis le site développeur

    Pour installer la dernière version stable de Firefox, directement depuis le site développeur, suivez les étapes ci-dessous:

    Première étape. Allez sur la page de téléchargement de Firefox

    Figure 1: Bouton de téléchargement de Firefox

    Deuxième étape. Cliquez sur le bouton [Téléchargement gratuit] pour télécharger le dossier d'installation Firefox.

    Troisième étape. Enregistrer le dossier d'installation Firefox dans un emplacement de votre choix, tel que votre Bureau ou votre dossier Documents.

    Dans cette section, nous considérons que le dossier d'installation Firefox est sur votre Bureau.

    Quatrième étape. Accédez au dossier dans lequel vous avez enregistré le dossier d'installation Firefox

    Figure 2: Le dossier d'installation Firefox

    Cinquième étape. Double-cliquez sur le dossier d'installation pour accéder au fichier.

    Figure 3: Contenu du dossier Firefox

    Sixième étape. Cliquez sur [Extraire] pour choisir un emplacement pour le dossier de l'application Firefox

    Figure 4: Choix d'un emplacement pour extraire le dossier de l'application Firefox

    Septième étape. Accédez à l'emplacement où vous souhaitez extraire le dossier de l'application Firefox

    Huitième étape. Cliquez sur [Extraire] pour extraire le dossier de l'application Firefox

    Figure 5: Extraction du dossier de l'application Firefox

    Neuvième étape. Cliquez sur [Fermer] pour revenir à l'archive Firefox

    Figure 6: Contenu de l'archive Firefox

    Dixième étape. Cliquez sur le X dans le coin supérieur droit pour fermer l'archive Firefox

    Onzième étape. Accédez à l'emplacement où vous avez extrait le dossier de l'application Firefox au cours des étapes précédentes.

    Figure 7: Dossier de l'application Firefox

    Douzième étape. Ouvrez le dossier Firefox

    Figure 8: Contenu du dossier de l'application Firefox

    Treizème étape. Double-cliquez sur le fichier firefox pour lancer le navigateur Firefox

    Firefox vous demandera si vous souhaitez en faire votre navigateur par défaut, comme indiqué ci-dessous

    Figure 9: Ecran Firefox "Navigateur par défaut"

    Quatorzième étape. (Facultatif) Décochez Toujours vérifier au lancement de Firefox

    Astuce. Si vous prévoyez d'utiliser cette installation sur d'autres ordinateurs, vous devriez Décochez cette case.

    Quinzième étape. Cliquez soit sur [Plus tard] ou [Utiliser Firefox comme navigateur par défaut] pour ouvrir le navigateur Firefox

    Figure 10: Fenêtre du navigateur Firefox

    2.2. Paramétrer les moteurs de recherche

    Vous pouvez paramétrer Firefox pour utiliser le moteur de recherche de votre choix. Pour cela, suivez-les étapes ci-dessous :

    Première étape. Sélectionnez Options > Préférences dans la barre de menu de Firefox.

    Figure 1: Préférences de recherche Firefox

    Deuxième étapeCliquez sur [Recherche] dans la barre latérale de l'écran Préférences.

    Vous pouvez maintenant choisir votre moteur de recherche par défaut et définir quels moteurs de recherche devrait être accessible via la zone de recherche de Firefox. Nous recommandons DuckDuckGo comme moteur de recherche par défaut car il ne localise pas, ne fait pas de profil de ses utilisateurs et ne partage pas les informations personnelles de ses utilisateurs avec un tiers.

    Il existe d'autres outils de recherche que vous pouvez choisir d'ajouter comme options du moteur de recherche. Vous pouvez ajouter ces moteurs de recherche dans la barre de recherche Firefox, par exemple :

    2.3. Configurer les options "vie privée"

    Vous pouvez configurez les paramètres « Vie Privée » de Firefox en suivant les étapes ci-dessous :

    Première étapeSélectionnez Options > Préférences  dans la barre de menu de Firefox en bas.

    Figure 1 : Paramètres Vie Privée de Firefox

    Deuxième étape. Cliquez sur [Vie Privée] dans la barre latérale de l'écran des Options.

    Vous pouvez maintenant modifier les paramètres "Vie privée" de Firefox liés au pistage, à l'historique et à l'historique de recherche en suivant les étapes ci-dessous :

    Troisième étape. De nombreux sites Internet collectent des informations sur vous et autorisent des tiers à récolter des informations sur les sites Internet que vous consultez. On appelle ça du pistage.  Do Not Track est un système qui permet à des utilisateurs de se désengager du suivi des sites Internet qu'ils consultent, y compris les services analytiques, les réseaux de publicité et les plateformes de réseaux sociaux.

    Pour activer Do Not Track dans Firefox et minimiser le pistage de votre activité en ligne, sélectionnez les deux options sous la section Pistage. Il est important de comprendre, cependant, que les sociétés ont la capacité d'ignorez votre choix et de vous pister malgré cela. Voici une liste des engagements des sociétés qui respectent les requêtes Do Not Track.

    Quatrième étape. La section Historique vous permet de gérer vos préférences d'historique sur Firefox. Votre historique de recherche est une liste des sites Internet que vous avez consultés en utilisant Firefox. L'option par défaut est Conserver l'historique, ce qui signifie que Firefox conservera les données de navigation, les téléchargements, les formulaires et l’historique de recherche, et les cookies des sites visités. Il acceptera aussi les cookies des sites Internet que vous visitez. Ces cookies permettent aux sites Internet d'enregistrer des informations sur votre appareil que Firefox enverra de nouveau aux sites Internet et à leurs partenaires publicitaires.

    Pour empêcher ceci, dans la première option sous Historique, l'option 'Règles de conservation', vous pouvez choisir de Conserver historique ou Ne jamais conserver l'historique. Ou vous pouvez choisir  Utiliser les paramètres personnalisés de l'historique et définir des préférences plus détaillées dans la section Historique.

    Cinquième étape. La section Barre d'adresse vous permet de choisir les sources que Firefox utilisera pour recommander les adresses Internet lorsque vous commencerez la saisie dans la Barre d'adresse. Par défaut, il utilise les marque-pages, les onglets ouverts et votre historique de navigation. Vous pouvez décocher chacune des options selon votre préférence.

    2.4. Configurer les options de sécurité

    Vous pouvez configurer les Paramètres de sécurité de Firefox en suivant les étapes ci-dessous :

    Première étape. Sélectionnez Options > Préférences dans le menu de votre moteur de recherche.

    Figure 1: Options de sécurité de Firefox

    Deuxième étape. Cliquez sur [Sécurité] dans la barre latérale de l'écran des Options.

    Vous pouvez maintenant modifier les paramètres de sécurité de Firefox.

    Toutes les cases sous Général devrait être cochées. Si elles ne le sont pas, nous vous recommandons de le faire, ainsi Firefox :

    • vous avertira lorsque des sites Internet essayeront d'installer des modules complémentaires,
    • bloquera des contenus dangereux,
    • bloquera des sites trompeurs.

    Les cases sous Identifiants concernent la gestion des mots de passe intégrée à Firefox. Si vous cochez la case Utiliser un mot de passe principal, Firefox chiffrera les mots de passe que vous sauvegardez et vous demandera un mot de passe principal à chaque fois qu'il est nécessaire. Généralement, nous recommandons l'utilisation d'un outil de gestion des mots de passe hors ligne, comme KeePassX, pour conserver vos mots de passe. Mais, si vous autorisez Firefox à gérer vos mots de passe, vous devez cocher la deuxième case.

    2.5. Paramétrez les options avancées

    Vous pouvez configurer différentes préférences avancées pour Firefox en suivant les étapes ci-dessous :

    Première étape. Sélectionnez Options > Préférences dans la barre de menu de Firefox en bas.

    Figure 1: Options avancées de Firefox

    Deuxième étape. Cliquez sur [Avancé] dans la barre latérale de l'écran des Options.

    L'écran Avancé contient cinq onglets :

    • Général : qui contient diverses options d'accessibilité et de navigation,
    • Données collectées : qui vous permet de choisir quelles sont les données relatives à la santé et les performances de votre navigateur envoyées à Mozilla,
    • Mises à jour : qui vous permet de définir comment Firefox gère les mises à jour automatiques (y compris les mises à jour de votre moteur de recherche par défaut),
    • Réseau : qui vous permet de gérer les paramètres de connexion, le contenu web en cache et le contenu web et les données utilisateur hors connexion,
    • Certificats : qui vous permet de définir comment Firefox doit gérer les certificats de chiffrement (à la fois lorsque les sites Internet exigent un certificat personnel de votre navigateur et lorsque Firefox essaye de définir si oui ou non un certificat https présenté par un site Internet est valide.)

    L'onglet Général présente une option utile qui autorise Firefox à empêcher les redirections automatiques depuis des sites internet et les rechargements de pages sans vous demander votre accord ou vous avertir.

    Figure 2: Onglet General de l'écran des préférences Avancées

    Troisième étape. Cochez la case [Prévenir lorsque des sites web tentent de rediriger ou de recharger la page].

    2.6 Utilisations des fonctionnalités relatives à la vie privée lors de recherches sur le net

    En plus des paramétrages décrits ci-dessus, Firefox fournit deux fonctionnalités utiles qui vous donnent le contrôle des données que vous stockées sur votre ordinateur et sur les sites Internet que vous visitez. Il s'agit de l'écran effacer votre historique récent et le Mode de navigation privée.

    Effacer l'historique récent

    Pour effacer les données de votre historique de rechercher que Firefox a déjà stockées, suivez les étapes décrites ci-dessous :

    Première étape. Appuyez sur les touches Ctrl, Maj et suppr simultanément pour activer l'écran Effacer l'historique récent. (Sinon, vous pouvez sélectionnez Historique > Effacer l'historique récent dans la barre de menu.)

    Figure 1: Effacer l'historique récent dans Firefox

    Deuxième étape. Cliquez sur la flèche à côté du mot Détails pour étendre la liste de ce qui sera effacé

    Figure 2: Choix des informations de recherches à effacer

    Troisième étape. Cochez les cases à côté des types de données de recherche que vous souhaitez être effacées par Firefox.

    Dans cet exemple, nous effacerons tout sauf Données de site web hors connexion et Préférences de site. Si vous utilisez cette fonctionnalité pour la première fois, vous voudrez peut-être commencer par quelque chose de moins radical.

    Quatrième étape. Cliquez sur les mots à côté de "Intervalle à effacer", pour voir jusqu'à quel instant Firefox ira quand il effacera vos données de recherche.

    Figure 3: Période à effacer

    Cinquième étape Sélectionnez la période pour laquelle vous souhaitez que Firefox efface votre historique

    Dans cet exemple, nous effacerons toutes les données de navigation (sauf Données de site web hors connexion et Préférences de site). Encore une fois, Si vous utilisez cette fonctionnalité pour la première fois, vous voudrez peut-être commencer par quelque chose de moins radical.

    Figure 4: Firefox est prêt à effacer vos données de recherche

    Sixième étape. Cliquez sur [Effacez maintenant] pour effacer les données de navigation sélectionnées.

    Une solution alternative consiste à utiliser la navigation privée de Firefox pour éviter tout enregistrement de votre historique de recherche.

    Navigation privée

    Pour empêcher Firefox de stocker des données sur votre session de navigation actuelle, suivez les étapes décrites ci-dessous :

    Première étape. Appuyez sur les touches Ctrl, Maj et P simultanément pour ouvrir une fenêtre de navigation privée. (Vous pouvez également sélectionner Fichier > Nouvelle fenêtre de navigation privée dans la barre de menu de Firefox)

    Figure 5: Une fenêtre de navigation privée Firefox

    Deuxième étape. Naviguez sur le web en utilisant cette fenêtre.

    Firefox n'enregistrera pas vos données de navigation tant que vous utilisez cette fenêtre. Ceci inclut n'importe quel onglet que vous souhaiteriez ouvrir. La fenêtre présente quelques exceptions comme les téléchargements et les marque-pages. Elle vous rappelle également que Firefox ne pourrait empêcher ceux qui veulent contrôler votre connexion internet (y compris votre FAI) de pister les sites Internet que vous visitez. Pour cela, vous aurez besoin de Tor Browser.

    3. Modules complémentaires de Firefox

    Un module complémentaire (ou plugin) de Firefox est un logiciel qui ajoute de nouvelles fonctionnalités ou étend les fonctionnalités déjà existantes. Les modules complémentaires incluent les plugins, comme Adobe Flash, et les extensions comme NoScript. Cette section montre comment désactiver des plugins potentiellement dangereux, et présente ensuite quelques extensions liées à la vie privée et à la sécurité, notamment :

    D'autres modules complémentaires respectueux de la vie privée sont présentés dans le Tactical Tech App Centre.

    3.1. Mise à jour ou désactivation des plugins potentiellement dangereux

    Les plugin Adobe Shockwave Flash et Oracle Java browser sont souvent considérés comme présentant des failles de sécurité qui pourraient permettre à un utilisateur distant de prendre contrôle de votre ordinateur ou installer des logiciels malveillants. Il est fortement recommandé de désactiver ces deux plugins dans Firefox. Pour savoir comment désactiver ou supprimer Java, veuillez consulter le guide Oracle étapes pour désactiver Java de tous vos navigateurs sur votre ordinateur. Vous pouvez mettre à jour vos modules complémentaires, suivez les étapes ci-dessous. Pour désactiver Adobe Shockwave Flash, voir la Neuvième étape, ci-dessous.

    Première étape. Lancez Firefox

    Figure 1: Firefox

    Deuxième étape. Cliquez sur le bouton dans le coin supérieur droit de votre fenêtre de navigateur

    Figure 2: Menu d'options de Firefox

    Troisième étapeCliquez sur le bouton [Modules]

    Figure 3: Menu Modules de Firefox

    Quatrième étape. Cliquez sur l'onglet Plugins sur le côté gauche de la fenêtre

    Figure 4: Menu des options Firefox

    Cinquième étape. Cliquez sur le lien Vérifier si vos plugins sont à jour pour ouvrir l'onglet Vérifier vos Plugins

    Figure 5: Onglet Firefox Vérifier vos Plugins

    Sixième étape. Faites dérouler vers le bas pour vérifier que tous vos plugins sont identifiés par Firefox.

    Figure 6: Plugins supplémentaires sur l'onglet 'Vérifier vos plugins'

    Tous vos plugins devraient appartenir à l'une ou l'autre de ces catégories :

    • Si tous vos plugins sont à jour, poursuivez avec la neuvième étape, ci-dessous
    • Certains de vos plugins apparaissent à côté de l'icône [Recherche]. Si vous cliquez sur [Recherche], Firefox affichera les résultats de recherche qui pourraient vous aider à mettre à jour les plugins correspondants.
    • Si l'un de vos plugins apparaît à côté du bouton [Mettre à jour maintenant], vous devriez cliquer dessus et suivre les instructions. Dans l'image ci-dessus, Adobe Flash Player est un exemple de plugin à mettre à jour.

    Malheureusement, cette méthode peut ne pas fonctionner pour mettre à jour certains plugins - notamment Adobe Flash Player - à moins de mettre d'abord à jour une liste de logiciels que votre système sait installer. Pour cela, suivez les étapes ci-dessous.

    Septième étape. Lancez l'application Software Updater disponible dans votre distribution Linux. Elle lancera automatiquement l'actualisation de la liste des logiciels qu'il sait installer et mettre à jour.

    Figure 7: 'Software Updater' d'Ubuntu actualisant sa liste de logiciels

    Huitième étape. Acceptez et installez toutes mises à jour identifiées par Software Updater. Vous serez averti lorsque ces mises à jour seront installées.

    Figure 8: 'Software Updater' d'Ubuntu, une fois que tout est mis à jour

    Neuvième étape. Cliquez sur [OK]

    Lorsque le Software Updater a terminé, vous pouvez redémarrez votre ordinateur, si nécessaire, re-vérifiez dans Firefox qu'Adobe Shockwave Flash a été mis à jour.

    Cependant, les failles relatives à Flash sont extrêmement courantes, le support d'Adobe pour le plugin Linux est limité. Vous devriez désactiver le plugin Flash même si vous pouvez le mettre à jour Pour désactiver le plugin Adobe Shockwave Flash, suivez les étapes ci-dessous.

    Dixième étape. Revenez à l'onglet de gestion des Modules complémentaires affichant tous vos plugins Firefox

    Figure 9: Ecran des Plugins Firefox

    Onzième étape. Cliquez sur Toujours activer si la coche est affichée à côté Shockwave Flash

    Figure 10: Menu d'activaton de Shockwave Flash

    Douzième étape. Selectionez Ne jamais activer pour désactiver Adobe Shockwave Flash.

    Figure 11: Adobe Shockwave Flash disabled

    Remarque : Si vous sélectionnez Demander avant d'activer, Firefox vous avertira lorsqu'un site Internet essaye de vous envoyer du contenu Flash. Vous aurez ensuite la possibilité de cliquer sur [Autoriser], dans le coin supérieur droit de votre fenêtre de navigateur comme indiqué ci-dessous. Cependant, nous recommandons de complètement désactiver Flash.

    Figure 12: Firefox vous demande d'autoriser le contenu Flash

    3.2. HTTPS Everywhere

    HTTPS Everywhere est un module complémentaire qui permet à Firefox de se connecter en de façon sûre aux sites Internet qui sont compatibles avec le chiffrement.

    Lorsque vous accédez à une page en utilisant une adresse Internet commençant par "http://" (comme http://www.amazon.com), votre connexion n'est pas chiffrée. Les informations que vous envoyez et recevez de ce site Internet peuvent être envoyées à quiconque ayant la capacité de contrôler votre trafic Internet. Cela inclut votre FAI et de nombreuses plateformes de surveillance.

    Lorsque vous accédez à une page en utilisant une adresse Internet commençant par "https://" (comme https://www.amazon.com), votre connexion sera chiffrée et les tierces parties auront plus de difficultés à intercepter les données que vous envoyez et recevez. Malheureusement, mêmes les sites Internet qui sont compatibles avec https manquent souvent de rediriger correctement les visiteurs vers la bonne adresse Internet. C'est le problème que HTTPS Everywhere essaye de résoudre.

    HTTPS Everywhere maintient une liste de sites Internet qui sont compatibles avec https et exige automatiquement une connexion chiffrée pour ces sites – même si vous cliquez sur un lien (ou saisissez une adresse dans votre navigateur) qui commence par http.

    Pour installer HTTPS Everywhere, suivez les étapes décrites ci-dessous :

    Première étape. Sélectionnez Modules > Extensions dans la barre de menu de votre navigateur, comme indiquez ci-dessous :

    Deuxième étape: Dans la section “Rechercher dans tous les modules”, saisissez [HTTPS Everywhere] dans la barre de recherche et appuyez sur 'Entrée'. Vous devriez maintenant avoir une liste de tous les modules complémentaires devant vous, y compris HTTPS Everywhere.

    Figure 1: Recherche du module HTTPS-Everywhere pour Firefox

    Troisième étapeCliquez sur [Installer] à côté de HTTPS Everywhere, pour télécharger et installer le module complémentaire.

    Figure 2: Installation de HTTPS-Everywhere

    Quatrième étape: Redémarrez votre navigateur Firefox pour installer HTTPS Everywhere.

    Cinquième étape: Vérifier que HTTPS Everywhere a été installé correctement en sélectionnant Options > Modules > Extensions dans la barre de menu Firefox. HTTPS Everywhere devrait apparaître (à côté des autres modules).

    Figure 3: HTTPS-Everywhere est installé

    HTTPS Everywhere est maintenant installé. Lorsque vous accédez à un site Internet appartenant à la liste maintenue par le module et compatible avec https, votre connexion sera automatiquement chiffrée.

    Remarque :  Lorsque HTTPS Everywhere est actif, vous devriez toujours voir "https://" dans votre barre d'adresse. Si ce n'est pas le cas, alors votre connexion n'est pas chiffrée.

    Si vous cliquez sur “Préférences” à côté de HTTPS-Everywhere, la fenêtre suivante devrait apparaître :

    Figure 4: Ecran - Options "SSL Observatory" de HTTPS-Everywhere

    Ici, vous pouvez choisir si vous souhaitez utiliser EFF's SSL Observatory, qui vous avertit lors des attaques et des connexions non-sécurisées sur votre navigateur. Nous vous recommandons vivement d'utiliser cet SSL Observatory pour améliorer la sécurité de votre navigateur.

    3.3. Privacy Badger

    Privacy Badger est un module complémentaire de navigateur qui empêche une société tiers de pister votre activité en ligne. Il est disponible pour Firefox, le Navigateur TorChrome, et Chromium.

    Pour installer Privacy Badger, suivez les étapes ci-dessous:

    Première étape. Sélectionnez Options > Modules dans la barre de menu Firefox.

    Deuxième étape: Dans la section “Rechercher dans tous les modules”, Saisissez [Privacy Badger] dans la barre de recherche de l'écran Modules complémentaires et appuyez sur Entrée. Vous devriez maintenant avoir une liste de tous les modules complémentaires disponibles, y compris Privacy Badger.

    Figure 1: Recherche du module complémentaire Privacy Badger pour for Firefox

    Troisième étapeCliquez sur [Installer] à côté de Privacy Badger, pour télécharger et installer le module complémentaire.

    Figure 2: Installation de Privacy Badger

    Lorsque le module complémentaire est installé, Firefox affiche une page de remerciement de Privacy Badger.

    Figure 4: Privacy Badger vous remercie

    Quatrième étape. Vérifiez que Privacy Badger a été installé avec succès en sélectionnant Options > Modules > Extensions dans la barre de menu Firefox. Privacy Badger devrait apparaître à côté des autres modules complémentaires.

    Figure 4: Privacy Badger est installé

    Le module Privacy Badger est maintenant installé et vous aide à empêcher un tiers de pister vos activités en ligne. Vous pouvez cliquez sur [Options] pour modifier les paramètres « Vie privée » de Privacy Badger (même si les valeurs par défaut sont tout à fait satisfaisantes).

    3.4. Click&Clean

    Click&Clean est une extension de navigateur permettant d'effacer votre historique de navigation par un simple clic.

    Sans fonctionnalité avancée de sécurité, un navigateur peut collecter différent types d'informations stockées sur le disque dur de votre ordinateur. De telles informations peuvent être liées à votre position géographique, votre historique de recherche, des cookies, des caches, des identifiants de connexion actifs et des préférences concernant des sites Internet. Ce stockage local peut être supprimé en nettoyant manuellement l'historique de navigation avec un outil comme Click&Clean.

    Vous pouvez installer Click&Clean en suivant les étapes ci-dessous :

    Première étape. Sélectionnez Options > Modules dans la barre de menu du navigateur, comme indiqué ci-dessous :

    Deuxième étape: Dans la section “Rechercher dans tous les modules”, saisissez Click&Clean dans la barre de recherche et appuyez sur Entrée. Vous devriez maintenant avoir une liste de tous les modules complémentaires devant vous, y compris Click&Clean.

    Figure 1: Recherche du module complémentaire Click&Clean pour Firefox

    Troisième étape. Cliquez sur [Installer] à côté de Click&Clean, pour télécharger le module complémentaire.

    Figure 2: Installation de Click&Clean

    Quatrième étape: Redémarrez Firefox pour installer Click&Clean.

    Cinquième étape: Vérifiez que Click&Clean a été installé avec succès en sélectionnant Options > Modules > Extensions dans la barre de menu Firefox. Click&Clean devrait être affiché, avec vos autres modules complémentaires.

    Figure 3: Click&Clean est installé

    Sinon, observez simplement votre navigateur : l'icône Click&Clean devrait désormais apparaître. Si vous cliquez sur la flèche à côté, vous remarquerez qu'il propose différentes fonctionnalités comme la recherche incognito, des tests de contrôle de 'vie privée', des cookies, des autorisations et préférences.

    La fonction 'privacy test' vous permet de voir quels sont les services qui opèrent sur votre navigateur et que vous avez peut-être oubliés. La fonction cookies montre quels sont les cookies actuellement sauvegardés sur votre ordinateur. En utilisant la fonction permissions vous pouvez modifier les paramètres par défaut de votre navigateur pour améliorer vos paramètres de vie privée. Ces paramétrages/permissions comportent les fonctions de blocage ou de demandes de permission chaque fois que le navigateur souhaite enregistrer vos mots de passe, partager votre emplacement et utiliser votre caméra et votre microphone.

    Figure 4: Ecran d'autorisations Click&Clean

    Dans la section préférence vous pouvez choisir si vous souhaitez un nettoyage automatique de vos données de navigation. Vous pouvez également effacer votre historique de navigation à chaque fois que vous fermez votre navigateur, ainsi vous n'avez pas besoin de penser de nouveau à votre historique.

    Figure 5: Opions Click&Clean

    Remarque : Comme alternative, vous pouvez utiliser une application externe comme BleachBit.

    3.5. NoScript

    Lorsque vous consultez un site Internet, votre navigateur télécharge automatiquement le contenu du site. En plus du texte et des images, ce contenu comporte souvent des scripts qui sont principalement des petits programmes qui tournent dans votre navigateur. NoScript est un module de Firefox qui empêche votre navigateur de faire tourner de tels programmes sans votre accord.

    La grande majorité de ces scripts sont sans danger et sont destinés à rendre les pages plus interactives. Cependant, certains d'entre eux sont malveillants, et certains sont des traqueurs tirs utilisés par des tiers capables de définir un profile de vos activités en ligne.

    Malheureusement, No Script ne peut pas automatiquement identifier quels sont les scripts sans danger et lesquels sont malveillants. Donc lorsque vous décidez d'abord de bloquer l'intégralité des scripts (Block Scripts Globally), cela empêchera de nombreux sites Internet de s'afficher correctement. Une fois que vous commencez à créer votre liste d'exception de scripts à partir de différents sites, alors, les choses redeviendront normales et vous serez toujours protégé contre le contenu web dangereux.

    Pour installer NoScript, suivez les étapes décrites ci-dessous :

    Première étape. Sélectionnez Tools > [Modules] dans la barre de menu de votre navigateur.

    Deuxième étape: Dans la section “Recherchez dans tous les modules”, saisissez NoScript dans la barre de recherche et appuyez sur Entrée.

    Vous devriez avoir maintenant devant vous une liste de tous les modules disponibles, y compris NoScript.

    Figure 1: Recherche du Module complémentaire NoScript pour Firefox

    Troisième étape: Cliquez sur [Installer], à côté de NoScript, pour télécharger et installer le module complémentaire.

    Figure 2: Installation de NoScript

    Quatrième étape: Redémarrer Firefox pour installer NoScript.

    Cinquième étape: Vérifier que NoScript a été installé avec succès en sélectionnant Options > Modules > Extensions dans la barre de menu Firefox. NoScript devrait être affiché, à côté des autres modules complémentaires

    Figure 3: NoScript est installé.

    Votre navigateur utilise désormais NoScript et bloque tout code malveillant de tourner sur votre ordinateur.

    Même si NoScript peut paraître un peu frustrant au départ (car les site Internet que vous consultez ne s'afficheront pas forcément correctement), vous profiterez immédiatement des fonctionnalités d'auto-blocage automatique. Cela limitera les publicités, les messages pop-up, et le code malveillant existant (ou hacké) dans les pages Internet.

    NoScript tourne en silence en arrière-plan jusqu'à ce qu'il détecte la présence de JavaScript, Adobe Flash ou d'autres scripts affichant du contenu. A ce moment, NoScript bloquera ce contenu et la barre de statut apparaîtra sous le menu Firefox. La barre de statut NoScript affiche des informations sur les objets (par exemple les messages publicitaires et les pop-up) et les scripts qui sont actuellement bloqués sur votre système. Mais comme NoScript ne différencie pas le code malveillant du vrai code, certaines fonctionnalités clefs (par exemple, une barre de menu) peuvent être manquantes. Votre navigateur est désormais équipé de NoScript et empêche tout code malveillant d'être exécuté sur votre ordinateur.

    Certaines pages Internet présentent du contenu, notamment des scripts, provenant de plus d'un site Internet. Par exemple un site comme www.twitter.com a deux sources de scripts (twitter.com et twimg.com). Dans ce cas, pour débloquer ces scripts, commencez par sélectionner l'option Autoriser Temporairement [nom du site Internet] (dans cet exemple, Autoriser temporairement twitter.com). Cependant, si cela ne vous permet pas d'afficher la page, vous devrez déterminer, via un processus par tâtonnements, le nombre minimum de sites Internet nécessaires à l'affichage du contenu choisi. Par exemple, pour Twitter, vous avez besoin de sélectionner les options Autoriser temporairement twitter.com et Autoriser temporairement twimg.com, pour que Twitter fonctionne. Pour les sites Internet que vous consultez régulièrement et en qui vous avez confiance, sélectionnez l'option Autoriser[nom du site Internet]. Sélectionner cette option option autorise NoScript à enregistrer de façon permanente ce site comme étant de « confiance ».

    Remarque :  Une faille a récemment été identifiée dans NoScript. Nous continuons de recommander NoScript parce que cette faille ne présente pas de menace à moins d'installer également un module séparé (intentionnellement malveillant). Nous vous recommandons de faire des recherches sur les modules avant de les installer et de supprimer tout module dont vous n'avez pas besoin ou pour lequel vous n'êtes pas sûr de la sécurité.

    FAQ

    Q :  Pourquoi ai-je besoin de ces nombreux modules complémentaires pour me défendre contre les sites Internet malveillants ? Si NoScript me protège contre les scripts potentiellement dangereux, par exemple, pourquoi ai-je aussi besoin d'autres modules complémentaires qui fonctionnent de la même façon ?

    R : Il est souvent recommandé d'utiliser plus d'un outil pour résoudre la même question de sécurité générale (les programmes antivirus sont une exception importante à cette règle puisqu'ils ont tendance à entrer en conflit les uns avec les autres). Ces modules complémentaires Firefox utilisent des méthodes différentes pour protéger votre navigateur contre les menaces. NoScript, par exemple, bloque tous les scripts provenant de sites inconnus, mais les utilisateurs ont tendance à mettre sur liste d'exceptions les sites Internet qu'ils visitent fréquemment, ce qui leur permet de charger des scripts potentiellement malveillants. Les utilisateurs de NoScript ont aussi tendance à autoriser des sites inconnus à charger des scripts, de manière temporaire, si ces scripts sont nécessaires au bon fonctionnement de la page.