Firefox y complementos de seguridad para Linux - Navegador web seguro

Publicado10 August 2016

Tabla de contenido

...Loading Table of Contents...

    Mozilla Firefox (o conocido simplemente como Firefox) es un navegador web gratuito y de código abierto que mejora con la disponibilidad de numerosos complementos, incluidos algunos que están diseñados para proteger tu privacidad y seguridad cuando navegas por la web.

    Lectura obligatoria

    Qué obtendrás de esta guía

    • Un navegador de internet estable y seguro cuyas funciones pueden mejorar con numerosos complementos.
    • La capacidad de protegerte de programas potencialmente peligrosos y sitios web maliciosos.
    • La capacidad de borrar las huellas digitales de tus actividades de navegación.

    1. Introducción a Firefox

    Esta guía asume que ya conoces cómo usar un navegador web y no abarcará las funciones básicas de Firefox. Se enfocará en configuraciones y extensiones relacionadas con la seguridad.

    1.0 Lo que debes saber sobre Firefox antes de empezar

    Firefox tiene muchos complementos fáciles que mejoran tu privacidad y seguridad cuando navegas por la web. Puedes escoger qué complementos instalar y decidir cómo configurarlos, dependiendo de tus circunstancias. Si usas una computadora que otra persona administra (en un café internet, por ejemplo, o en tu centro de trabajo) es probable que debas hacer estas modificaciones reiteradamente.

    Además de configuraciones básicas de Firefox, esta guía abarca la instalación y configuración básica de los siguientes complementos:

    El Centro de Aplicaciones de Tactical Tech incluye información sobre complementos para mejorar más la privacidad en navegadores.

    Importante: La abrumadora mayoría de infecciones por software malicioso y software espía se originan en páginas web. Es importante que siempre evaúes si es seguro visitar sitios web desconocidos, particularmente los que te llegan por correo electrónico. Antes de decidir abrir una página web, te recomendamos que examines la direccion web usando las siguientes lectoras de URL:

    También puedes revisar la reputación de un sitio web usando las lectoras enumeradas a continuación:

    1.1 Otras herramientas como Firefox

    Herramentas similares y alternativas para otros sistemas operativos.

    El navegador web Mozilla Firefox está disponible para GNU/Linux, Apple Mac OS X, Microsoft Windows y otros sistemas operativos. Los sitios web son la fuente más común de infección con software malicioso, así que acceder a esos sitios web de manera segura es vital. Te recomendamos que uses Mozilla Firefox e instales los complementos que contempla esta guía. Si prefieres usar otro programa que no sea Mozilla Firefox, las alternativas a continuación también están disponibles para GNU/Linux, Apple Mac OS X y Microsoft Windows:

    2. Instalar, configurar y usar Firefox

    Muchas distribuciones de Linux vienen con Firefox instalado por defecto, y la mayoría tiene un sistema de administrador de paquetes o centro de software que facilita la instalación y actualización de Firefox (junto con cualquier otros software adicional que necesite para funcionar).

    Dato. Muchas distribuciones de Linux incluyen una versión libre de marcas registradas de Firefox llamada Iceweasel, que es la misma herrsamienta con un nombre diferente.

    2.1. Instalar o actualizar Firefox

    Probablemente ya tengas instalado Firefox (o Iceweasel). Pero si no es así — o si necesitas actualizarlo — puedes seguir las instrucciones en una de las secciones a continuación. Es extremadamente importante que tengas actualizado tu navegador web. Firefox es más fácil de actualizar si lo instalas usando tu sistema de administrador de paquetes o centro de software, así que recomendamos usar uno de los dos primeros métodos de abajo. Pero si por alguna razón necesitas la versión más reciente de Firefox — o si quieres instalar Firefox como una aplicación portátil (en un dispositivo de almancenamiento USB, por ejemplo) — la sección Instalar Firefox directamente del programador te mostrará cómo hacerlo.

    Dato: Normalmente, es una buena idea usar la versión más reciente de un software relacionado con la seguridad, incluidos navegadores web. Sin embargo, las distribuciones de Linux por lo general incorporan actualizaciones de seguridad para las versiones "más antiguas" de Firefox en sus sistemas de administración de paquetes y centros de software. Debido a esto — y como estas versiones son más fácil de actualizar — generalmente recomendados instalar y actualizar Firefox usando un sistema de administración de paquetes o un centro de software incorporado.

    2.1.1 (Opcional) Instalar o actualizar Firefox usando un administrador de paquetes de comandos

    Para instalar o actualizar Firefox usando el administrador de paquetes de comandos idóneo que viene con muchas distribciones de Linux (incluidos Debian y Ubuntu), sigue los pasos a continuación.

    Paso 1. Abre Terminal

    Paso 2. Ejecuta el siguiente comando en Terminal

    sudo apt-get update

    Paso 3. Escribe la contraseña que usas para iniciar sesión en tu computadora y presiona la tecla Enter.

    Esto recargará la lista de software que tu administrador de paquetes sabe cómo instalar y actualizar.

    Paso 4. Ejecuta uno de los siguientes comandos en Terminal

    • sudo apt-get install firefox
    • sudo apt-get install iceweasel

    2.1.2 (Opcional) Instalar o actualizar Firefox usando tu "centro de software"

    Para actualizar Firefox usando una aplicación gráfica del centro de software, sigue los pasos a continuación:

    Dato: Las instrucciones en esta sección están basadas en la distribución Ubuntu de Linux, pero muchas otras distribuciones incluyen algún centro de software. Algunas variantes de Debian también incluye una aplicación llamada Synaptic Package Manager, que ofrece una función similar. Si no encuentras una aplicación llamada Firefox, busca la que se llama Iceweasel. Como se dijo líneas arriba, es la misma aplicación con un nombre diferente.

    Paso 1. Inicia el Centro de Software

    Figura 1: Centro de software de Ubuntu

    Paso 2. Haz clic en la barra Buscar

    Paso 3. Escribe "Firefox"

    Figura 2: Buscar Firefox

    Paso 4. Haz clic en la línea que corresponde a Navegador web Firefox

    Figura 3: Centro de software mostrando que Firefox ya está instalado

    Si el botón a la derecha dice [Instalar], puedes instalar Firefox. Si dice [Eliminar], entonces Firefox ya está instalado. Sin embargo, aunque ya esté instalado, debes asegurarte de que esté actualizado siguiendo los pasos a continuación.

    Paso 5. Inicia la aplicación Actualizador de software que viene con tu distribución de Linux (si no lo hubiera, consulta la sección Instalar o actualizar Firefox usando un administrador de paquete de comando). Automáticamente empezará a recargar la lista de software que sabe cómo instalar y actualizar.

    Figura 4: Actualizador de software de Ubuntu recarga su lista de software

    Cuando esté hecho, te dirá si algún software en tu computadora (incluido Firefox) está desactualizado.

    Figura 5: Actualizador de software de Ubuntu muestra que todo el software está actualizado

    Si está actualizado, puedes hacer clic en [OK]. Si algún software necesita ser actualizado, te recomendamos que sigas las instrucciones del actualizador de software y que actualices todo. Después debes reiniciar tu computadora en cuanto sea conveniente.

    2.1.3 (Opcional) Instalar lFirefox directamente del programador

    Para instalar la versión estable más reciente de Firefox directamente del progamador, sigue los pasos a continuación:

    Paso 1. Anda a la página de descarga de Firefox

    Figura 1: Botón de descarga de Firefox

    Paso 2. Haz clic en el botón [Descarga gratis] para descargar el fichero del archivo de Firefox

    Paso 3. Guarda el fichero del archivo en algún lugar conveniente, como el Escritorio en tu carpeta Documentos.

    En esta sección, asumiremos que el fichero de Firefox está en tu Escritorio.

    Paso 4. Navega a la carpeta donde guardaste el fichero del archivo de Firefox

    Figura 2: Fichero del archivo de Firefox

    Paso 5. Haz doble clic en el fichero del archivo de Firefox para escribir el nombre del fichero

    Figura 3: Dentro del fichero de Firefox

    Paso 6. Haz clic en [Extraer] para escoger una ubicación para la carpeta de la aplicación Firefox

    Figura 4: Escoger una ubicación a donde extraer la carpeta de la aplicación Firefox

    Paso 7. Navega a la ubicacón a donde quieres extraer la carpeta de la aplicación Firefox

    Paso 8. Haz clic en [Extraer] para extraer la carpeta de la aplicación Firefox

    Figura 5: Extraer la carpeta de la aplicación Firefox

    Paso 9. Haz clic en [Cerrar] para regresar al fichero de Firefox

    Figura 6: Dentro del fichero de Firefox

    Paso 10. Haz cilc en la X en la esquina superior derecha para cerrar el fichero de Firefox

    Paso 11. Navega a la ubicación a donde has extraído la carpeta de la aplicación Firefox en los pasos anteriores

    Figura 7: Carpeta de la aplicación Firefox

    Paso 12. Entra a la carpeta de Firefox

    Figura 8: Dentro de la carpeta de la aplicación Firefox

    Paso 13. Haz doble clic en el archivo firefox para iniciar el navegador Firefox

    Firefox te preguntará si quieres que sea tu navegador por defecto, como se muestra abajo

    Figura 9: Pantalla de Firefox como "navegador por defecto""

    Paso 14. (Opcional) Saca la marca de Siempre realiza esta marca al iniciar Firefox

    Dato. Si planeas usar esta instalación en otras computadoras, debes sacar la marca de este recuadro.

    Paso 15. Haz clic en [Ahora no] o [Usar Firefox como mi navegador por defecto] para abrir el navegador Firefox

    Figura 10: Ventana del navegador Firefox

    2.2. Configurar motores de búsqueda

    Puedes configurar Firefox para usar el motor de búsqueda de tu elección. Para hacerlo, sigue los pasos a continuación:

    Paso 1: Elige Editar > Preferencias en la barra de menú de Firefox.

    Figura 1: Preferencias de búsqueda de Firefox

    Paso 2: Haz clic en Buscar en la barra lateral de la pantalla Preferencias.

    Ahora puedes escoger tu motor de búsqueda por defecto y decidir a qué otros motores de búsqueda se puede acceder a través del recuadro de búsqueda de Firefox. Recomendamos DuckDuckGo como motor de búsqueda por defecto pues no rastrea ni hace perfiles de sus usuarios, ni comparte la información personal de sus usuarios con terceros.

    Otros motores de búsqueda que se basan en la privacidad que puedes escoger para agregar como opciones de motor de búsqueda en la barra búsqueda de la barra de herramientas de Firefox incluyen:

    2.3. Configurar opciones de privacidad

    Puedes configurar los ajustes de privacidad de Firefox siguiendo los pasos a continuación:

    Paso 1: Elige Editar > Preferencias en la barra de menú de tu navegador Firefox.

    Figura 1: Ajustes de privacidad de Firefox

    Paso 2: Haz clic en Privacidad en la barra lateral de la pantalla de Preferencias.

    Ahora puedes cambiar las configuraciones de Firefox relacionadas con la privacidad, rastreo de terceros e historial de navegación siguiendo los pasos a continuación:

    Paso 3. Muchos sitios web recopilan información sobre ti y permiten que terceros reúnan información sobre los sitios web que visitas. A esto se le llama rastreo. Do Not Track, o No Rastrear, es un sistema que permite que los usuarios se excluyan del rastreo por parte de sitios web que no visitan, incluidos servicios de analíticas, redes de publicidad y plataformas sociales.

    Para habilitar No Rastrear en Firefox y minimizar el rastreo de tu actividad en línea, elige las dos opciones debajo de la sección Rastreo. Sin embargo, es importante entender que las empresas tienen la capacidad de ignorar tu elección y rastrearte de todas maneras. Esta es una lista de compromisos de empresas de cumplir las solicitudes de Do Not Track, o No rastrear.

    Paso 4. La sección Historial te permite administrar las preferencias de tu historial de navegación de Firefox. Tu historial de navegación es una lista de los sitios web que has visitado usando Firefox. La opción por defecto es Recordar mi historial de navegación y descarga, lo que significa que Firefox recordará tus historiales de navegación, descarga, forma y búsqueda. También aceptará cookies de los sitios web que visites. Estas cookies permiten a los sitios web registrar información en tu dispositivo que Firefox les enviará de vuelta y a sus socios anunciantes.

    Para evitar esto, en la primera opción debajo de Historial que empieza con Firefox hará:, puedes cambiar Recordar historial a No recordar historial nunca. O puedes cambiarlo a Usar configuraciones personalizadas para el historial y configurar preferencias más detalladas en la sección Historial.

    Paso 5. La sección Barra de ubicación te permite escoger las fuentes que usará Firefox para recomendar direcciones web cuando empieces a escribir en la Barra de direcciones. Por defecto, usa direcciones web marcadas como favoritas, pestañas abiertas y sitios web que están en el historial de tu navegador. Puedes sacar la marca de cualquiera de estas fuentes según tu preferencia.

    2.4. Configurar opciones de seguridad

    Puedes configurar los ajustes de seguridad de Firefox siguendo los pasos a continuación:

    Paso 1: Elige Editar > Preferencias en la barra de menú de tu navegador Firefox.

    Figura 1: Configuraciones de seguridad de Firefox

    Paso 2: Haz clic en Seguridad en la barra lateral de la pantalla de Preferencias.

    Ahora puedes modificar las configuraciones de seguridad de Firefox.

    Todos los recuadros debajo de General deben estar marcados. Si no están marcados, te recomendamos que los marques para que Firefox pueda:

    • Advertirte cuando los sitios web traten de instalar complementos
    • Bloquear ataques web que se hayan denunciado
    • Bloquear sitios web falsificados que se hayan denunciado

    Los recuadros debajo de Contraseñas se relacionan con el administrador de contraseñas incorporado de Firefox. Si marcas el recuadro de Usar una contraseña maestra, Firefox encriptará las contraseñas del sitio web que guarda y te dará aviso de una contraseña maestra cada vez que necesite escribir una contraseña por ti. En general, te recomendamos usar un administrador de contraseñas fuera de línea, como KeePassX, para guardar tus contraseñas. Pero, si vas a permitir que Firefox administre las contraseñas de tus sitios web, deberás marcar el segundo recuadro.

    2.5. Configurar opciones avanzadas

    Puedes configurar varias preferencias avanzadas para Firefox sigiuendo los pasos a continuación:

    Paso 1: Elige Editar > Preferencias en tu barra de menú del navegador Firefox.

    Figura 1: Preferencias avanzadas de Firefox

    Paso 2: Haz clic en Avanzadas en la barra lateral de la pantalla de Preferencias.

    La pantalla de Preferencias avanzadas contiene cinco pestañas:

    • General incluye varias opciones de uso fácil
    • Opciones de datos te permite escoger qué información enviar a Mozilla sobre la solidez, seguridad y desempeño de tu navegador
    • Actualizar te permite determinar cómo Firefox manejará las actualizaciones automáticas (incluidas actualizaciones a tus motores de búsqueda preferidos)
    • Red te permite administrar las configuraciones proxy, contenido web en caché e información de usuario fuera de línea
    • Certificados te permite decidir cómo debe tratar Firefox los certificados criptográficos (cuando los sitios web soliciten un certificado personal a tu navegador y cuando Firefox trate de determinar si el certificado https que presenta un sitio web es válido)

    La pestaña General incluye una opción útil que permite que Firefox evite que los sitios web te redirijan automáticamente a otra página o que se vuelvan a cargar sin tu consentimiento o conocimiento.

    Figura 2: Pestaña General de la pantalla de Preferencias avanzadas

    Paso 3. Marca el recuadro Advertirme cuando los sitios web traten de redirigir o recargar la página

    2.6 Usar funciones de privacidad al navegar la web

    Además de las configuraciones descritas líneas arriba, Firefox ofrece dos útiles funciones que te dan algo de control sobre la información que almacena en tu computadora y sobre los sitios web que visitas. Son la pantalla Limpiar historial reciente y Modo de navegación privada.

    Limpiar historial reciente

    Para limpiar la información sobre tu historial de navegación que Firefox ya tiene almacenada, sigue los pasos a continuación.

    Paso 1. Presiona las teclas Control, Mayúsculas y Suprimir al mismo tiempo para activar la pantalla Limpiar historia reciente (como alternativa, puedes elegir Historial > Limpiar historial reciente de la barra de menú).

    Figura 1: Pantalla de limpiar historial reciente

    Paso 2. Haz clic en la flecha al lado de la palabra Detalles para expandir la lista a lo que será borrado

    Figura 2: Qué tipo de información de navegación borrar

    Paso 3. Marca los recuadros cerca del tipo de información de navegación que quieres de Firefox borre.

    En este ejemplo, borraremos todo menos Información fuera de línea del sitio web y Preferencias del sitio. Si estás usando esta función por primera vez, tal vez prefieras empezar con algo menos agresivo.

    Paso 4. Haz clic en las palabras cerca de "Periodo a borrar", para ver hasta dónde iría Firefox al borrar tu información de navegación

    Figura 3: Periodo a borrar

    Paso 5 Elige el periodo cuyo historial quieres que Firefox borre

    En este ejemplo, borraremos toda la información de navegación (excepto Información fuera de línea del sitio web y Preferencias del sitio). De nuevo, si estás usando esta función por primera vez, tal vez prefieras empezar con algo menos agresivo.

    Figura 4: Firefox listo para borrar tu información de navegación

    Paso 6. Haz clic en [Borrar ahora] para borrar la información de navegación elegida.

    Como una alternativa a lo anterior, puedes usar Modo de navegación privada de Firefox para impedirle totalmente que registre tu historial.

    Modo de navegación privada

    Para impedir que Firefox almacene información sobre tu actual sesión de navegación, sigue los pasos a continuación.

    Paso 1. Presiona las teclas Control, Mayúsculas y P al mismo tiempo para abrir una ventana de Navegación privada (como alternativa, puedes elegir Archivo > Nueva ventana privada de la barra de menú).

    Figura 5: Ventana de navegación privada de Firefox

    Paso 2. Navega por la web usando esta ventana.

    Firefox no registrará tu información de navegación mientras uses esta ventana. Esto incluye todas las pestañas que puedes haber abierto adentro. La propia ventana nota algunas excepciones, incluidas descargas y marcas de favoritos. También te recuerda que el propio Firefox no puede evitar que quienes quieran seguir tu conexión de internet (incluido tu proveedor de servicio de internet) rastreen los sitios web que visitas. Para eso, necesitarás Tor Browser.

    3. Complementos de Firefox

    Un complemento de Firefox es un software que agrega nuevas funciones o extiende funciones existentes. Los complementos incluyen plugins, como Adobe Flash, y extensiones, como NoScript. Esta sección te mostrará cómo inhabilitar plugins potencialmente dañinos, luego presenta algunas útiles extensiones de privacidad y de seguridad, que incluyen:

    Se puede encontrar otros complementos para Firefox que protegen la privacidad a través del centro de aplicaciones de Tactical Tech.

    3.1 Actualizar o inhabilitar plugins potencialmente dañinos

    Con frecuencia, se encuentra que el plugin de Adobe Shockwave Flash y el plugin de navegador Oracle Java contienen vulnerabilidades de seguridad que podrían permitir que un usuario remoto asuma el control de tu computadora para instalar software malicioso. Se recomienda especialmente que inhabilites ambos plugins en Firefox. Para mayor información sobre cómo inhabilitar o eliminar Java, por favor consulta los pasos de Oracle para inhabilitar Java para todos los navegadores en tu computadora..

    Para actualizar tus plugins, sigue los pasos a continuación. Para inhabilitar Adobe Shockwave Flash, ver el Paso 9, más abajo.

    Paso 1. Inicia Firefox

    Figura 1: Firefox

    Paso 2. Haz clic en el botón en la esquina superior derecha de la ventana de tu navegador

    Figura 2: Menú de opciones de Firefox

    Paso 3. Haz clic en el botón Complementos

    Figura 3: Menú de Complementos de Firefox

    Paso 4. Haz clic en la pestaña de Plugins al lado izquierdo de la ventana

    Figura 4: Pantalla de plugins de Firefox

    Paso 5. Haz clic en el enlace Comprueba para ver si tus plugins están actualizados para abrir la pestaña Revisa tus plugins

    Figura 5: Pestaña Comprueba tu plugins de Firefox

    Paso 6. Desplázate hacia abajo para comprobar todos los plugins identificados por Firefox

    Figura 6: Más plugins en la pestaña Comprueba tus plugins

    Your plugins should fall into one of three categories:

    • Si todos tus plugins están actualizados, sigue con el Paso 9 abajo.
    • Algunos de tus plugins pueden aparecer al lado de un botón [Investigar]. Si haces clic en [Investigar], Firefox mostrará resultados de búsqueda que podrían ayudarte a actualizar el plugin correspondiente.
    • Si alguno de tus plugins aparece al lado del botón [Actualizar ahora], debes hacer clic en ese botón y seguir las instrucciones. En la figura de arriba, Adobe Flash Player es un ejemplo de un plugin no actualizado.

    Lamentablemente, este método puede no funcionar para actualizar algunos plugins — incluido Adobe Flash Player — a menos que primero actualices la lista de software que tu sistema sabe cómo instalar. Para hacerlo, sigue los pasos a continuación.

    Paso 7. Inicia la aplicación Actualizador de software que viene con tu distribución de Linux. Automáticamente empezará a recargar la lista de software que sabe cómo instalar y actualizar.

    Figura 7: Actualizador de software de Ubuntu recarga su lista de software

    Paso 8. Acepta e instala todas las actualizaciones identificadas por el Actualizador de software. Te dirá cuando esas actualizaciones estén instaladas.

    Figura 8: Actualizador de software de Ubuntu con todo ya actualizado

    Paso 9. Haz clic en [OK]

    Cuando el Actualizador de software haya terminado, puedes reiniciar tu computadora, de ser necesario, luego revisar con Firefox para asegurarte de que Adobe Shockwave Flash ha sido actualizado.

    No obstante, las vulnerabilidades de Flash son extremadamente comunes, y el respaldo de Adobe para el plugin de Linux es limitado. Así que deberías inhabllitar el plugin de Flash aunque puedas actualizarlo. Para inhabilitar el plugin de Adobe Shockwave Flash, sigue los pasos a continuación.

    Paso 10. Regresa a la pestaña Administrador de complementos que e muestra todos tus plugins de Firefox

    Figura 9: Pantalla de plugins de Firefox

    Paso 11. Haz clic en Activar siempre si está visible al lado de Shockwave Flash

    Figura 10: Menú de activación de Shockwave Flash

    Paso 12. Elige Activar nunca para inhabilitar Adobe Shockwave Flash.

    Figura 11: Adobe Shockwave Flash inhabilitado

    Nota: Si eliges Pedir activar, Firefox te avisará cuando un sitio web trate de enviarte contenido Flash. Entonces tendrás la opción de hacer clic en [Permitir], en la esquina superior derecha de la ventana de tu navegador, como se muestra abajo. Sin embargo, recomendamos que inhabilites Flash completamente, sobre todo si no has podido actualizarlo a la versión más reciente.

    Figura 12: Firefox te pide que autorices contenido Flash

    3.2. HTTPS Everywhere

    HTTPS Everywhere es un complemento que ayuda a Firefox a conectarse de manera segura a sitios web que operan con encriptación.

    Cuando accedes a una página usando una dirección web que empieza con "http://" (como http://www.amazon.com), tu conexión no está encriptada. La información que envíes y recibas de ese sitio web la puede ver cualquier persona con la capacidad de seguir tu tráfico de internet. Esto incluye a tu (proveedor de servicio de internet) and muchas plataformas de vigilancia.

    Cuando accedes a una página usando una dirección web que empieza con "https://" (como https://www.amazon.com), tu conexión estará encriptada y será mucho más difícil que terceros intercepten la información que envíes y recibas. Lamentablemente, hasta los sitios web que operan con https a menudo no logran redirigir a los visitantes a la dirección web correcta. Para resolver este problema es que se diseñó HTTPS Everywhere.

    HTTPS Everywhere mantiene una lista de sitios web que operan con https y automáticamente solicita una conexión encriptada para esos sitios web —aunque hagas clic en un enlace (o escribas una dirección en tu navegador) que empiece con http.

    Para instalar HTTPS Everywhere, sigue los pasos a continuación:

    Paso 1: Elige Herramientas > Complementos en la barra de menú de tu navegador Firefox.

    Paso 2: En la sección “Obtener Complementos”, escribe HTTPS Everywhere en la barra de búsqueda y presiona la tecla enter. Ahora debes tener una lista de todos los complmentos disponibles frente a ti, incluido HTTPS Everywhere.

    Figura 1: Encontrar el complemento HTTPS-Everywhere para Firefox

    Paso 3: Haz clic en [Instalar], al lado de HTTPS Everywhere, para descargar e instalar el complemento.

    Figura 2: Instalar HTTPS-Everywhere

    Paso 4: Reinicia tu navegador Firefox para instalar HTTPS Everywhere.

    Paso 5: Verifica que HTTPS Everywhere se haya instalado satisfactoriamente seleccionando Herramientas > Complementos > Extensiones en la barra de menú de Firefox. Se debería ver HTTPS Everywhere junto con los demás complementos.

    Figura 3: HTTPS-Everywhere instalado

    HTTPS Everywhere ya está instalado. Cuando te conectes con un sitio web que esté incluido en la lista que el complemento mantiene y que opera con https, tu conexión será encriptada automáticamente.

    Nota. Cuando HTTPS Everywhere esté funcionando, todavía debes ver "https://" en la barra de direcciones de tu navegador. Si no es así, entonces tu conexión no está encriptada.

    Si haces clic en “Preferencias” al lado de HTTPS-Everywhere, aparecerá la siguiente ventana:

    Figura 4: Pantalla de "Preferencias de Observatorio SSL" de HTTPS-Everywhere

    Acá puedes escoger si quieres usar el Observatorio SSL de EFF, que te advierte de conexiones inseguras o ataques a tu navegador. Te recomendamos que usar este Observatorio SSL para mayor seguridad de tu navegador.

    3.3. Privacy Badger

    Privacy Badger es un complemento del navegador que evita que empresas externas rastreen tus actividades en línea. Está disponible para Firefox, Tor Browser, Chrome y Chromium.

    Para instalar Privacy Badger, sigue los pasos a continuación:

    Paso 1: Elige Herramientas > Complementos en la barra de menú de tu navegador Firefox.

    Paso 2: En la sección “Obtener Complementos”, escribe Privacy Badger en la barra de búsqueda y presiona la tecla enter. Ahora debes tener una lista de todos los complementos disponibles frente a ti, incluido Privacy Badger.

    Figura 1: Encontrar el complemento Privacy Badger para Firefox

    Paso 3: Haz clic en [Instalar], al lado de Privacy Badger, para descargar e instalar el complemento.

    Figura 2: Instalar Privacy Badger

    Cuando el complemento esté instalado, Firefox mostrará la página de "Gracias" de Privacy Badger

    Figura 3: Página de "Gracias" de Privacy Badger

    Paso 4: Verifica que Privacy Badger se haya instalado satisfactoriamente eligiendo Herramientas > Complementos > Extensiones en la barra de menú de Firefox. Privacy Badger debería aparecer, junto con los otros complementos.

    Figura 4: Privacy Badger instalado

    El complemento Privacy Badger ya está instalado y puede ayudar a evitar (rastreo de terceras personas](/en/glossary#third-party-trackers) de tus actividades en línea. Puedes hacer clic en [Preferencias] para cambiar las configuraciones de Privacy Badger (aunque los valores por defecto están bien).

    3.4. Click&Clean

    Click&Clean es una extensión de navegador que te ayuda a limpiar tu historial de navegacion con un solo clic.

    Sin las funciones de mejora de la privacidad, un navegador puede recopilar diferentes tipos de información que guarda en el disco duro de tu computadora. Esa información puede incluir tu ubicación, historial de navegación, historial de búsqueda, cookies, memoria caché, inicios de sesión activos y preferencias de los sitios web. Este almacenamiento local se puede borrar limpiando manualmente tu historial de navegación con una herramienta como Click&Clean.

    Puedes instalar Click&Clean a través de los siguientes pasos:

    Paso 1: Elige Herramientas > Complementos en la barra de menú de tu navegador Firefox.

    Paso 2: En la sección “Obtener Complementos”, escribe Click&Clean en la barra de búsqueda y presiona la tecla enter. Debes ya tener una lista de todos los complementos disponibles frente a ti, incluido Click&Clean.

    Figura 1: Encontrar el complemento Click&Clean de Firefox

    Paso 3: Haz clic en [Instalar], al lado de Click&Clean, para descargar el complemento

    Figura 2: Instalar Click&Clean

    Paso 4: Reiniciar tu navegador Firefox para terminar de instalar Click&Clean.

    Paso 5: Verifica que Click&Clean se instaló satisfactoriamente eligiendo Herramientas > Complementos > Extensiones en la barra de menú de Firefox. Click&Clean debería aparecer junto con tus otros complementos.

    Figura 3: Click&Clean instalado

    Alternativamente, simplemente mira tu navegador – el ícono de Click&Clean ya debería estar ahí. Si haces clic en la flecha a su costado, verás que ofrece una variedad de funciones, como navegación de incógnito, pruebas de privacidad, cookies, permisos y preferencias.

    La función de prueba de privacidad te ofrece la capacidad de ver qué servicios se están ejecutando en tu navegador que podrías haber olvidado. La función de cookies te muestra qué cookies están almacenadas actualmente en tu computadora. Usando la función de permisos puedes cambiar las configuraciones por defecto de tu navegador para mejorar tu privacidad. Estos configuraciones/permisos incluyen bloquear o pedir permiso cada vez que el navegador quiera almacenar tus contraseñas, compartir tu ubicación y usar tu cámara y micrófono. Abajo se muestran algunos ejemplos de cómo puedes configurar las permisos de tu navegador:

    Figura 4: Pantalla de permisos de Click&Clean

    En la sección de preferencias también puedes escoger si quieres hacer automática la limpieza de la información de tu navegador. También puedes limpiar tu historial de navegación cada vez que cierres tu navegador, para que no tengas que pensar en borrar de nuevo tu historial de navegación.

    Figura 5: Pantalla de preferencias de Click&Clean

    Nota: Como alternativa, puedes usar una aplicación externa como BleachBit para este propósito.

    3.5. NoScript

    Cuando visitas un sitio web, tu navegador descarga automáticamente contenido de ese sitio. Además de texto e imágenes, este contenido a menudo incluye secuencias de comandos, que esencialmente son pequeños programas que se ejecutan dentro de tu navegador. NoScript es un complemento de Firefox que evita que tu navegador ejecute esos programas sin tu permiso.

    La gran mayoría de estas secuencias de comandos son inocuas y sirven solamente para hacer que las páginas web sean más interactivas. Sin embargo, algunas son maliciosas, y algunas pueden rastreadores de terceros elaborar un perfil de tus actividades en línea.

    Lamentablemente, No Script no puede identificar automáticamente qué secuencias de comandos son seguras y cuáles son dañinas. Así que cuando le digas Bloquear secuencias de comando totalmente, evitará que muchos sitios web se muestren adecuadamente. No obstante, una vez que empieces una lista aprobada de secuencias de comando desde diferentes ubicaciones, las cosas empezarán a volver a la normalidad, y seguirás estando protegido de contenido web potencialmente peligroso.

    Para instalar NoScript sigue los pasos a continuación:

    Paso 1: Elige Herramientas > Complementos en la barra de menú de tu navegador Firefox.

    Paso 2: En la sección “Obtener complementos”, escribe NoScript en la barra de búsqueda y presiona la tecla enter. Ahora debes tener a la vista una lista de todos los complementos disponibles, incluido NoScript.

    Figura 1: Encontrar el complemento NoScript para Firefox

    Paso 3: Haz clic en [Instalar] al lado de NoScript para descargar e instalar el complemento.

    Figura 2: Instalar NoScript

    Paso 4: Reinicia Firefox para instalar NoScript.

    Paso 5: Verifica que NoScript se haya instalado satisfactoriamente eligiendo Herramientas > Complementos > Extensiones en la barra de menú de Firefox. NoScript debería aparecer, junto con tus otros complementos.

    Figura 3: NoScript instalado

    Tu navegador ahora opera con NoScript y bloquea código malicioso para que no se ejecute en tu computadora.

    Aunque al principio NoScript puede parecer un poco frustrante (pues los sitios que siempre has visitado pueden no mostrarse adecuadamente), inmediatamente te beneficiarás de la función automática de bloqueo de objetos. Esto restringirá anuncios molestos, mensajes emergentes y código malicioso elaborado (o que haya penetrado) en páginas web.

    NoScript se ejecutará silenciosamente en el trasfondo hasta que detecte la presencia de JavaScript, Adobe Flash u otro contenido de tipo secuencias de comandos. En ese punto, NoScript bloqueará este contenido y la barra de estado aparecerá en la parte inferior de la ventana de Firefox. La barra de estado de NoScript muestra información sobre qué objetos (por ejemplo, anuncios y mensajes emergentes) y secuencias de comandos están impedidos de ejecutarse en tu sistema. Pero como NoScript no diferencia entre código malicioso y real, pueden faltar algunas caracteristicas y funciones claves (por ejemplo, una barra de herramientas).

    Algunas páginas web presentan contenido, incluido contenido del tipo secuencia de comandos, desde más de un sitio web. Por ejemplo, un sitio web como www.twitter.com tiene dos fuentes de secuencias de comandos (twitter.com y twimg.com). Para desbloquear las secuencias de comandos en estas circunstancias, empieza eligiendo la opción Permitir temporalmente [nombre del sitio web] (en este ejemplo, Permitir temporalmente twitter.com). Sin embargo, si esto no te permite ver la página, puedes determinar, a través de un proceso de ensayo y error, la cantidad mínima requerida de sitios web para ver tu contenido elegido. Por ejemplo, en Twitter, debes elegir las opciones Permitir temporalmente twitter.com y Permitir temporalmente twimg.com, para que Twitter funcione. Para sitios web en los que confías y visitas con frecuencia, elige la opción Permitir [nombre del sitio web]. Elegir esta opción permite que NoScript enumere permanentemente ese sitio web como confiable.

    Nota: Una vulnerabilidad en NoScript fue identificada recientemente. Seguimos recomendando NoScript porque esta vulnerabilidad no representa una amenaza a menos que también instales un complemento aparte (intencionalmente malicioso). Recomendamos especialmente investigar los complementos antes de instalarlos y retirar cualquier complemento que no necesites o de los que no estés seguro.

    PREGUNTAS FRECUENTES

    P: ¿Por qué necesito tantos complementos diferentes para defenderme de sitio web maliciosos? Si NoScript me protege de secuencias de comandos potencialmente peligrosas, por ejemplo, ¿por qué necesito también otros complementos que funcionan de manera similar?

    R: Con frecuencia es una buena idea usar más de una herramienta para abordar el mismo problema de seguridad general (los programas antivirus son una importante excepción a esta regla, pues tienden a entrar en conflicto entre ellos). Estos complementos de Firefox usan técnicas muy diferentes para proteger tu navegador de una variedad de amenazas. Por ejemplo, NoScript bloquea todas las secuencias de comandos de sitios web desconocidos, pero los usuarios tienden a 'autorizar' los sitios web que visitan frecuentemente, lo que les permite cargar secuencias de comandos potencialmente maliciosos. Los usuarios de NoScript también tienden a permitir que sitios web desconocidos carguen secuencas de comandos, de manera temporal, si esas secuencias de comandos son necesarias para que la página funcione adecuadamente.